WWW의 미래

정주원
대전 광역시 유성구 구성동 373-1
한국과학기술원 경영정보연구센터
E-mail : jwjung@camis.kaist.ac.kr
URL : http://camis.kaist.ac.kr/~jwjung/
Abstract:
본 강의에서는 작년 12월에 열렸던 국제 WWW 학술대회의 논문들을 참고로 하여 WWW가 어떻게 움직여 갈 것인가를 조심스럽게 예상해 본다.

특히, 현재의 신문을 대치하게 될 internet media로서, 또한, 인터넷 상에서의 내용물 규제와 같은 사회적인 요소의 하나로서 WWW를 살펴보며, 그로인해 파생되는 사회적 요구사항을 해결하기 위한 기술로서의 WWW 신기술들을 살펴본다.

Keywords:
WWW, HTML, HTTP, PICS

1. 서론

WWW는 1993년 Mosaic이 인터넷에 알려지면서 매년 그 사용량이 기하급수적으로 증가하고 있다. [Cailliau 95] 인터넷에 WWW가 나타난 지 3년이 겨우 지났을 뿐인데, HTML은 version 3.0을 준비하고 있다. 96년 3월 현재, 나온지 일년도 안되는 Java라는 물건이 Mosaic, Netscape에 이어 전 세계를 휩쓸고 있다.

WWW의 미래에 대해서 말하라면 글쓴이도 뭐라 할말이 없다. 왜냐하면 너무나 빠른 속도로 바뀌고 있기 때문이다. 그렇다고 해서 남들이 하는 대로 쫓아가기만 할 수는 없는 일이다. 그래서, 글쓴이 나름대로 현상들을 관찰, 분석하고 WWW의 미래를 만들어 가기 위한 제안을 하고자 한다.

2. 기본 구성 요소의 변화

WWW의 기본 구성 요소는 HTML, HTTP, URL이라 할 수 있다. 이것들은 WWW가 나타난 이후 계속 발전되어가고 있다.

2.1. HTML

HTML 2.0
95년 9월 RFC 1866, proposed standard로서 발표되었다. 이것이 첫번째 draft가 아닌 HTML specification이다. 그럼에도 불구하고 Netscape, Microsoft 등의 회사들에 의해 HTML Tag의 확장은 계속되고 있다.
HTML 3.0
어찌된 일인지 expire 된지 6개월이 다 되도록 소식이 없다. 그럼에도 불구하고 HTML 3.0에 multimedia object를 붙이는 작업을 진행 중이다. (http://www.w3.org/pub/WWW/TR/WD-insert.html)
HTML 국제표준으로
MHEG(Multimedia Hypermedia Expert Group)에서 HTML을 하나의 Object로 규정, 국제 표준화 작업을 추진하고 있다. 초기에는 HTML의 meta language인 SGML을 Object로 규정할 의도였으나 추후에 HTML로 목표를 변경했다.
MHEG에 포함될 HTML은 HTML 1.1과 HTML table 그리고 국제화에 관한 부분들을 합쳐놓은 것이다. 이것을 HTMLcore라 부른다. HTMLcore에 붙여질 이름은 MHEG의 부분이라는 의미에서 MHEG-2, ISO 번호로는 ISO/IEC 13522-2이다. JTC1/SC29/WG12에서이 작업을 하고 있다.
국제화(Internationalization)
RFC-1866 HTML 2.0에서는 HTML의 character set을 ISO-10646 UCS으로 모호하게 지정했을 뿐, 다른 언어로 된 문서를 만들기 위한 방법을 지정하지는 않았다. 따라서 이것을 위한 작업을 진행중에 있으며 현재 draft 2까지 나온 상황이다.
그밖의 Extension들
Form-based Upload in HTML(RFC-1867), HTML tables(draft 6), Client-Side Image Maps(draft 2)

2.2. HTTP

HTTP 1.0
초기에 포함되어 있던 content negotiation등의 내용을 빼고 HTTP가 되기 위한 최소의 조건만을 기술하였다. Propose Standard RFC로 제안하였으나 되지 못하고 Infomative RFC로 진행 중이다. (draft 5)
HTTP 1.1
HTTP 1.0 초기에 있던 content negotiation기능 뿐 아니라 hierarchical caching, messege digest등의 기능이 추가되었다. (draft 1)
HTTP-NG
HTTP는 한번의 요구와 한번의 대답으로 하나의 object를 가져오는 구조를 가지고 있다. 이것은 문서안에 그림, 음성, 영상등의 다른 데이타들을 포함하고 있을때는 재 접속이라는 성능상의 저하를 유발시킨다. 이런 경우를 위해서 OSI 7 layer model에서는 session layer를 제안하고 있다. 따라서 TCP위에 session layer를 구현하고 그 위에 HTTP를 구현함으로써 성능 향상 및 다른 기능들을 추가하고자 하는 것이다.
PEP(Protocol Extention Protocol)
HTML이나 URI쪽을 변경내지 확장하다 보면 HTTP를 확장해야 할 필요가 생긴다. 그러나 프로토콜의 확장이라는 것이 그리 쉽지 않아서, 한쪽만 지원한다고 되는 것이 아니다. 그렇다고 확장 한번 할때마다 버젼 번호를 높일수도 없는 일이다.
PEP는 확장된 프로토콜의 이름을 붙이는 방법, 상대방이 확장된 프로토콜을 가지고 있는지 확인하는 방법, 확장된 프로토콜이 있을 경우 그를 사용하는 방법과 같은 규칙들을 정의한다.

2.3. URI

Relative URL (RFC-1808)
Unix나 DOS의 화일시스템에서는 ../other_dir과 같이 화일이나 디렉토리를 상대적으로 지정할 수 있다. URL에는 기본적으로 ..이나 .인 directory는 정의되어 있지 않으므로 ..에 대한 해석이 구현에 따라 다를 수 밖에 없다. 이와 같이 상대적으로 URL을 변경하는 방법을 통일한 것이 RFC-1808 Relative URL이다.

3. 새로운 기술의 출현

3.1. Mobile Code

1995년 한해는 Java의 한해라고 해도 과언이 아닐 정도로 Java의 인기는 폭발적이었다. 1995년 4월, HotJava alpha1이라는 WWW browser의 모습으로 처음 나타난 Java는 1년이 채 안된 지금, Netscape, IBM, Microsoft를 포함한 대부분의 network/software 회사들의 개발대상으로 혹은 개발도구로 사용되고 있다.

Java의 제일 큰 매력은 문서가 아닌 프로그램이 전달되어 실행된다는 점에 있을 것이다. 이와 같이 프로그램이 네트워크를 통해 전달되어 상대편에서 실행되도록 만든 구조를 Mobile Code System이라고 한다.

Mobile Code가 갖추어야 할 요건중의 하나가 다양한 platform에서 실행될 수 있어야 한다는 점이다. (사실, Network를 통한 전달은 HTTP나 FTP등 많은 전송 프로토콜이 존재하므로 별 문제가 되지 않는다.) Perl이나 Tcl과 같은 다용도 script언어는 여러 platform에서 사용할 수 있도록 개발이 되어 왔다. 따라서 이런 언어들로 Mobile Code System을 구성할 수 있다. Perl과 Tcl은 많은 사용자를 보유하고 있으며 여러 종류의 library가 개발되어 있다는 점에서 Java에게 충분한 위협이 될 수 있다.

Tcl을 Mobile Code로서 사용한 것으로는 Safe-Tcl이라는 것이 있으며, Perl을 사용한 것으로는 Penguin이라는 것이 있다. Python이란 언어를 사용한 Safe-Python, Scheme을 사용한 scheme48등 여러 종류가 있다.

자세한 것은 http://www.w3.org/pub/WWW/MobileCode을 참조하기 바란다.

3.2. Plug-in

1995년 WWW에 있었던 또 하나의 변화라면 Netscape 2.0의 발표와 Microsoft사의 Windows 95 및 Internet Explorer의 발표를 들 수 있다.

Netscape 2.0의 특징중에 하나로서 Plug-in을 들 수 있는데, 이것은 Netscape 기능의 확장을 위해서 Microsoft Windows 3.1/NT/95용 DLL을 추가할 수 있도록 만든 것이다. Microsoft의 Internet Explorer에도 이와 유사한 형태로 Plug-in spec을 정의하였다.

Plug-in은 Windows 3.1/NT/95에서만 실행되는 문서를 만들어낸다. 이것은 Workstation과 Machintosh를 포함한 대부분의 platform에서 동작한다는 장점을 없애기는 하지만, MS Windows의 특성들을 쉽게 WWW로 옮길 수 있다는 측면에서 주목하고 있다.

4. 사회와 인터넷 기술

4.1. 자유냐 보호냐 -- blue ribbon과 PICS

지난 2월 초, 웬만한 미국의 많은 웹 사이트들의 배경이 시커멓게 된 적이 있었다. 이것은 미국의 인터넷 사업자, 사용자들이 CDA(Communications Decegency Act:통신품위법)라는 법에 항의하기 위한 하나의 시위였다.

이 법의 내용은 인터넷상에서 음란물등을 올린자에게 형사상 처벌을 할 수 있다는 것이었는데, 이 법은 국민의 기본권인 표현의 자유를 제한한다는 것이 시위에 참여한 사람들의 주장이었다. 그들의 말에 따르면, "길거리에서 흔히 볼 수 있는 성적 유혹이 담긴 잡지나 광고를 인터넷에서는 볼 수 없다는 것은 말이 안된다."는 것으로 새로운 매체로서의 인터넷의 가능성을 제한해서는 안된다는 의미도 포함되어 있다.

그러면, 인터넷은 어린이에게 음란, 폭력영화를 보는 정도의 해를 입히지 않는가 생각해 보자. 지난 2월 2일 연합통신의 기사중에는 인터넷을 통해 폭탄을 만들다 발각된 세명의 소년에 대한 이야기가 있다. (http://matrix.mdn.com/jconline/1996/02/02/0202709.html)

만 13세인 이 소년들은 자신들의 학교를 폭파시키고자 폭탄을 제조하였는데, 폭탄제조에 필요한 모든 지식을 인터넷을 통해 얻었다는 것이다. 전문가들은 이들이 인터넷의 도움을 받지 않고서는, 도저히 그와 같은 대량 살상이 가능한 폭탄을 만들 수 없다고 밝혔다.

실제로 글쓴이가 Search Engine들을 사용하여 찾아본 결과, 10분만에 폭탄제조법에 관한 문서를 구할 수 있었고, 그 문서안에는 폭탄의 기본원리 뿐 아니라 실제로 만드는 방법, 화합물을 섞을때 주의해야 할 사항등은 물론 필요한 화학약품을 어떻게 구해야 하는지까지 상세히 적혀져 있었다.

인터넷에 내용물을 제한하자니 모처럼 만든 인터넷이 애들 놀이터가 되겠고, 그렇다고 그냥 놔두자니 유해한 면이 있고. 이런 경우 해결할 수 있는 방법은 영화관에서 영화의 등급을 매기듯이 인터넷의 내용물에 전부 등급을 매기는 방법이 있을 수 있다.

PICS(Platform for Internet Content Selection)는 W3C에서 연구하고 있는 인터넷 자료의 등급매기기 시스템이다. 이미 SurfWatch와 같은 회사에서는 보안에 사용되는 IP filtering 기술을 사용하여 몇몇 자료에 대해서는 browser자체에서 접속을 제한하는 프로그램과 등급별 URL list를 판매하고 있다. 그러나 이러한 회사들이 늘어나다 보니 서로 호환성이 없고, 똑같은 결과를 얻기위한 중복투자가 계속되므로 이를 위한 표준으로서 진행하고 있다.

자세한 내용은 http://www.w3.org/pub/WWW/PICS/를 참조하기 바란다.

4.2. 신문한장 보는 값 -- Millicent Protocol

신문과 잡지는 현재 나와있는 인쇄매체들 중에서 가장 수명주기가 짧고 양이 많은 것으로, 환경보호론자들에게는 가장 먼저 없어져야 할 것들 중에 하나로 꼽고있다. 생각해 보라, 신문의 수명주기는 하루인데 그것이 전국의 가정에 배달된다. (그 많은 양의 신문을 만들기 위한 종이는 어디서 나며, 하루가 지난후 그대로 쓰레기가 되어 버리는 그것들을 어떻게 처리할 것인가?)

따라서 앞으로는 신문도 WWW 또는 그와 유사한 전자매체를 통해 보게 될 것이다. 그러면, 어떤식으로 요금을 매겨야 할까? 지금처럼 한달에 얼마씩 내는 것으로 하는 것이 좋을까?

쉽게 생각할 수 있는 가장 합리적인 방법은 HTML 페이지 한장당 얼마씩 매기는 것이다. 그러나 이런식으로 요금을 매기려면 요금을 받는 돈보다 요금을 매기는 돈이 훨씬 더 든다.

특히 현재 지불방식으로 주로 사용되는 공개키 암호방식은 계산량이 많다. 계산량이 많다는 것은 속도가 느리다는 것이고, 속도가 느리다는 것은 결국 단위시간내에 처리할 수 있는 일의 양, 여기서는 한시간에 요금을 매길 수 있는 페이지 수가 적어진다는 것을 의미한다. 컴퓨터를 운영하려면 전기비 뿐만 아니라 운영비용이 들어가므로 결국 요금을 다 받아 봤자 컴퓨터 운영비도 안 나온다.[Glassman 95]

Digital사에서는 이와같이 적은 요금을 자주 매기는 경우의 문제를 해결하기 위해 Millicent Protocol을 제안하였다. 이것은 보다 싸고 효율적인 요금 체계로서, 계산 시간이 오래 걸리는 공개키 암호방식은 처음에 사용자를 만들때만 사용하고, 실제 요금을 부과하는 단계에서는 그보다 계산 시간이 덜 걸리는 Messege Digest Algorithm을 사용하였다.

Millicent에 대한 자세한 내용은 http://www.research.digital.com:80/SRC/millicent/를 참조하기 바란다.

4.3. Internet Homeless -- Scalability

Internet Homeless라는 말이 있다. 우리나라 말로 직역하자면 인터넷 무주택자 정도 될 것 같다. Homeless가 집없는 사람들을 이야기 하듯이 Internet Homeless는 Internet계정이 없는 사람을 말하는 것이다.

글쓴이는 이 말을 WWW Conference의 Politics BOF에서 처음 들었다. 신문도 인터넷으로 읽게 되고, 각종 거래 및 정보 수집을 인터넷에서 하게 되는 세상이 되는데, 어떠한 이유로 해서 인터넷 계정이 없으면 이러한 혜택을 못 받는다. 이것은 결국 기회의 불평등, 즉 비민주적이므로 국가 및 사회는 모든 국민이 인터넷의 혜택을 받을 수 있도록 배려해야 한다는 것이 Intenet homeless 문제의 핵심이다.

사회적인 의미는 일단 뒤로 해두고 기술적인 의미에서 Internet Homeless를 생각해보자. 국민 한사람당 최소 인터넷 계정 하나는 무엇을 의미하는가? 그것은 학자들이 계속 경고해 왔던 scaleability 문제가 현실화된다는 것을 의미한다.

우리나라의 경우만 따져서, 인구 4000만 중에서 1000만이 아침에 일어나서 XX일보를 읽는다고 해 보자. 한 페이지 읽는데 20초 정도 걸린다고 가정하면 XX일보 서버는 평균적으로 초당 50만개의 연결요구를 처리해야 한다. 한 연결요구에 대해 80 byte씩 log가 쌓인다고 하면 초당 4000만 byte, 즉 40M씩 디스크 용량이 log로 사용된다. 이것은 1 Terabyte (= 1000 Gbyte)하드를 log전용으로 사용한다 하더라도 25,000초, 약 7시간이면 꽉 차 버린다는 이야기이다.

설사 XX일보가 전국에 100대의 컴퓨터를 설치하여 분산처리한다 하더라도 앞의 숫자에서 동그라미를 두개 줄이거나 늘일 뿐이다. 거기다가 요금까지 매긴다고 생각해 보자. log의 크기가 1초에 40M씩 늘어나는 상황에서 요금은 더 말할 나위도 없을 것이다. 거기다가 해외교포와 한글을 읽을 수 있는 외국인을 포함시킨다면 문제는 점점 더 심각해진다.

더 큰 문제는, 이 문제가 먼 훗날의 이야기가 아니라 앞으로 곧 나타날 문제라는 것이다.

5. 결론

이제까지 기술적인 측면, 개발적인 측면, 사회적인 측면에서 95년 한해동안 일어난 WWW의 변화에 대해서 간단하나마 살펴보았다.

WWW가 실생활에 응용되고 있고, 세인의 관심이 되고 있는 이상, WWW는 기술적인 것만이 아니다. 따라서, WWW의 미래 역시 기술적인 측면만으로는 예측이 불가능하다.

과거, 특히 최근 1년간의 WWW의 변화를 볼때, WWW는 더이상 인터넷 과학기술자들만의 관심대상이 아니며, 일반국민들, 즉 사회전반에까지 큰 영향을 주고 있다. 그에 따라 사회에서는 새로운 문제들이 발생되며 그 문제들을 해결하기 위해 새로운 기술과 그의 구현이 이루어 지고 있다.

이러한 현상은 인터넷의 설비가 잘 되어있고, 인터넷의 내용중 대부분이 그들의 모국어로 되어있는 미국에서 많이 나타나며, 정치에도 반영이 되고 있다. 혹자는 과연 정당이 Homepage를 만들어 공개해도 되는가, 인터넷을 통한 선거운동을 어느 정도까지 허용할 것인가를 이야기한다. 그만큼 그들에게 있어 인터넷은 별개의 세상이 아닌 그들이 정복해야 할 "또하나의 신대륙"인 것이다.

만약에 WWW의 미래를 만드는데 동참하고자 한다면, WWW라는 기술에 너무 치중하기 보다는 WWW를 이해하면서 WWW가 영향을 주고 있는 것들에 대해서도 이해해야만 할 것이다.

참고문헌(References)

[Cailliau 95]
Cailliau, "WWW: A Little History", Last updated 03 October 1995
URL: http://www.w3.org/hypertext/WWW/History.html
[Glassman 95]
Steve Galssman, Mark Manasse, Martín Abadi, Paul Gauthier, Patrick Sobalvarro, "The Millicent Protocol for Inexpensive Electronic Commerce," 4th Intl. WWW Conf., 1995
URL: http://www.w3.org/pub/WWW/Journal/1/gauthier.246/paper/246.html

Last-Modified : Thursday, 14-Mar-96 11:13:15 KST